Author Topic: HyperNext compatible with OS 10.7?  (Read 2961 times)

jcloud

  • Newbie
  • *
  • Posts: 1
HyperNext compatible with OS 10.7?
« on: July 02, 2013, 02:42:30 AM »
When I install HN and try to open Creator I get a message that says it cannot be opened because this system no longer supports PowerPC applications. Is there a newer version than 2007?

Thanks

Malkom

  • Administrator
  • Newbie
  • *****
  • Posts: 381
  • Here to help you
Re: HyperNext compatible with OS 10.7?
« Reply #1 on: July 02, 2013, 05:55:57 AM »
When I install HN and try to open Creator I get a message that says it cannot be opened because this system no longer supports PowerPC applications. Is there a newer version than 2007?

Thanks
Yes, unfortunately HyperNext Studio 3 was built using a compiler that only targeted PowerPC so when Apple dropped support for PowerPC apps in OS X Lion it also affected HyperNext.

HyperNext 4 is nearly ready, hopefully end of this month. It already runs on OS X Lion while still running/building on OS X PowerPC and later. However, although there will be a demo, the full version will cost $24.99 as its going to be continuously developed again.

Best Regards
Malkom

I am sorry but I do not have time to answer questions by PM or email.
If you post your questions in this forum then it might help others.

richmond62

  • Newbie
  • *
  • Posts: 20
Re: HyperNext compatible with OS 10.7?
« Reply #2 on: March 08, 2015, 09:25:22 AM »
"the full version will cost $24.99"

I wonder how that will boost uptake?

Runtime Revolution Livecard [ http://livecode.com/download/ ] has a two-tier system; a commercial version which protects the developer's code when s/he spins off a standalone,
and an Open Source version without that protection. Their uptake has increased immensely since they released their Open Source version, and there is demonstrable
uptake of the commercial version by people after using the Open Source version for some time.

The presence of an Open Source version means that a lot of people are prepared to spend a lot of time bug-hunting and reporting which accelerates their development team's work.
They release a beta version on average every 2 to 6 weeks.

richmond62

  • Newbie
  • *
  • Posts: 20
Re: HyperNext compatible with OS 10.7?
« Reply #3 on: March 08, 2015, 09:20:30 PM »
Come to think of things HyperNext is competing directly with Runtime Revolution Livecode. Now while people can download
a free (as in Open Source) version of a RAD-IDE that offers far more features and platforms than HyperNext for no money
at all why would they pay 25 pounds for HyperNext.

Surely, what is needed is some way to generate uptake and make HyperNext more attractive in certain ways to Livecode?

One of the ways to do that would be to release an Open Source (or just plain FREE) version with certain restrictions,
and a pay version without those restrictions (certainly 25 pounds undercuts Livecode Commercial).

Malkom

  • Administrator
  • Newbie
  • *****
  • Posts: 381
  • Here to help you
Re: HyperNext compatible with OS 10.7?
« Reply #4 on: May 17, 2015, 06:28:17 AM »
HyperNext v4 runs on OS X 10.7 so built apps/stacks etc will on the most modern Macs.


Below are OS X v4 & v3 comparisons:-

v4 Mac: OS X (Mactel or PPC) v10.1 to Yosemite(10.10).

v3 Mac: Classic OS 9 to OS X 10.1(Mactel or PPC) to Snow Leopard(10.6).


Note, v4 can load v3 projects but not visa versa.
« Last Edit: May 17, 2015, 06:35:31 AM by Malkom »
I am sorry but I do not have time to answer questions by PM or email.
If you post your questions in this forum then it might help others.