Author Topic: Standalone Location & Movie Help  (Read 308 times)

Dystopia

  • Newbie
  • *
  • Posts: 2
Standalone Location & Movie Help
« on: October 22, 2020, 05:57:06 AM »
I tried compiling my program. It goes through alright. Now I'm having issues finding where it puts the file.

As for movies, when I run my program and try to start the movie, it doesn't start. What am I doing wrong?

Malkom

  • Administrator
  • Newbie
  • *****
  • Posts: 405
  • Here to help you
Re: Standalone Location & Movie Help
« Reply #1 on: October 22, 2020, 05:20:04 PM »
I tried compiling my program. It goes through alright. Now I'm having issues finding where it puts the file.
When HN builds an app(executable) or stack, it places the built app/stack in the project's folder.
For instance if your project is called My Movie Player, then the built app/stack should be in the My Movie Player folder.

Note, when releasing your app or stack, the original project file is not required but remember to make a copy of it somewhere.
Only the app/stack plus any dependencies such as datafiles, images, vidoe setc are required.


As for movies, when I run my program and try to start the movie, it doesn't start. What am I doing wrong?
There is a bug in a movie player's control panel that prevents some movies such as MP4 from playing.

See number 5 in this post:-
http://www.tigabyte.com/smf/index.php?topic=326.0

However, it is possible to control a movie, play or pause it by using the relevant movie command.
 
In the scripts below, the movie player control on the card has ID 1.

The movie to be played was dragged and dropped intoto the project's movie library via the Movie Library menu option  under the menu Windows.
 

Use one button  to play the movie with the command MoviePlayNormalSpeed:-
Code: [Select]
MoviePlayNormalSpeed(1)


Use another button  to pause the movie with the command MoviePause:-
Code: [Select]
MoviePause(1)


As a movie player's controller is bugged, it can be hidden using the command MovieSetController.
Its usual to place this or similar commands in the card's open event:-
Code: [Select]
MovieSetController(1,0)



Attached below is a simple movie player that has a small movie in the project folder.

More MP4 movies can be found here:-
https://file-examples.com/index.php/sample-video-files/sample-mp4-files/

I am sorry but I do not have time to answer questions by PM or email.
If you post your questions in this forum then it might help others.

Dystopia

  • Newbie
  • *
  • Posts: 2
Re: Standalone Location & Movie Help
« Reply #2 on: October 23, 2020, 08:04:33 PM »
I tried compiling my program. It goes through alright. Now I'm having issues finding where it puts the file.
When HN builds an app(executable) or stack, it places the built app/stack in the project's folder.
For instance if your project is called My Movie Player, then the built app/stack should be in the My Movie Player folder.

Note, when releasing your app or stack, the original project file is not required but remember to make a copy of it somewhere.
Only the app/stack plus any dependencies such as datafiles, images, vidoe setc are required.


As for movies, when I run my program and try to start the movie, it doesn't start. What am I doing wrong?
There is a bug in a movie player's control panel that prevents some movies such as MP4 from playing.

See number 5 in this post:-
http://www.tigabyte.com/smf/index.php?topic=326.0

However, it is possible to control a movie, play or pause it by using the relevant movie command.
 
In the scripts below, the movie player control on the card has ID 1.

The movie to be played was dragged and dropped intoto the project's movie library via the Movie Library menu option  under the menu Windows.
 

Use one button  to play the movie with the command MoviePlayNormalSpeed:-
Code: [Select]
MoviePlayNormalSpeed(1)


Use another button  to pause the movie with the command MoviePause:-
Code: [Select]
MoviePause(1)


As a movie player's controller is bugged, it can be hidden using the command MovieSetController.
Its usual to place this or similar commands in the card's open event:-
Code: [Select]
MovieSetController(1,0)



Attached below is a simple movie player that has a small movie in the project folder.

More MP4 movies can be found here:-
https://file-examples.com/index.php/sample-video-files/sample-mp4-files/



Thank you! I still can't find my project folder, but the movie issue is resolved. Another has appeared, though. When I put in a 'go back' button on my movie's card and click it, it takes me back to the desired card, but the movie doesn't go away. How do I fix this? I've tried MovieSetView, MovieViewFN, and such to no avail.
« Last Edit: October 23, 2020, 08:46:03 PM by Dystopia »

Malkom

  • Administrator
  • Newbie
  • *****
  • Posts: 405
  • Here to help you
Re: Standalone Location & Movie Help
« Reply #3 on: October 26, 2020, 06:03:14 AM »
Thank you! I still can't find my project folder.

About your project folder. If you forgot to create a new project then the default project folder will  be used.

The path is  something like: C:\Users\Malkom\Documents\My HyperNext 4\Default_CR

The path will be roughly  similar for OS X.

Note,
If you want to turn your project in the default folder into a new project, for instance MoviePlayer then:
  • Copy the folder - Default_CR to another location.
  • Rename the Default_CR folder to MoviePlayer.
  • Inside the new project folder, rename Default_CR.prj to MoviePlayer.prj.



When I put in a 'go back' button on my movie's card and click it, it takes me back to the desired card, but the movie doesn't go away. How do I fix this? I've tried MovieSetView, MovieViewFN, and such to no avail.

This is actually a bug when the movie player doesn't hide on a card without its own movie player.

A workaround is to add the the follwing in your target card's open event:

Code: [Select]
MovieSetHeight(1,0)

MovieSetView(1,0)

If you want it in the button, then disable the Button Goto, and place this in the button's script:

Code: [Select]
MovieSetHeight(1,0)

MovieSetView(1,0)

Gotocard 2
« Last Edit: October 26, 2020, 07:57:38 AM by Malkom »
I am sorry but I do not have time to answer questions by PM or email.
If you post your questions in this forum then it might help others.

 

anything